I have encountered a peculiar bug in FFXIII-2 on X360 that I am hoping someone could help me address. Hope this is the right area of the forum.

I am guessing there's a flag that needs to be reset somehow, but I am unsure how to do it myself. The issue is as follows: During the first visit to a Dying World you play as Serah searching for Noel. Right after the cutscene with Noel and Caius where Noel says he has chosen the two bladed style, you are supposed to proceed to investigate the village with 'red-outlined people' and Mog should follow you, as he is needed to make them visible. However, Mog does not follow me; he just remains at the entrance to the village. I can't call him to me, and I can't use Bubble except when I stand right next to him; unfortunately all the targets are out of reach. At this point you can't pick him up and throw him either. I only have one save game, which has about 36 hours of play on it, so this bug is extremely annoying as it prevents me from progressing in the game.



I've tried clearing the system cache, and I tried using the Genesis editor (fantastic btw) to open up all the timelines, but unfortunately this still does not allow me to progress in the game as Dying World changes when I open up the timelines with Genesis and I appear in a different location; the gate doesn't work and the Historia Crux still only shows Dying World, Serendipity and Colisseum. If anyone with greater save editing skills thinks they might be able to help, I will gladly e-mail you the save file (.dat) in question (prior to edits). In fact, this is my only hope of being able to finish the game at this point... I can be reached at [email protected]. Any help anyone can provide is greatly appreciated!